diff --git a/CHANGELOG.md b/CHANGELOG.md
index 39818b5969044e13b90ab5980253851307081ebc..1da5cbec5e2c8cc74c6b37cd935ea6fa48ba1f0d 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -3,6 +3,12 @@
 The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/), and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).
 
 ---
+## [2.5.0-bb.0] - 2026-02-13
+
+### Updated
+
+- Updated Kiali and Kiali-operator to v2.5.0
+
 ## [2.4.0-bb.2] - 2026-02-06
 
 ### Changed
diff --git a/README.md b/README.md
index 9f4215e6e9885b97f321affcab93700fbba33010..c6a8aac0677b4a5ad792a57898b25dfa6f31c2f3 100644
--- a/README.md
+++ b/README.md
@@ -1,7 +1,7 @@
 <!-- Warning: Do not manually edit this file. See notes on gluon + helm-docs at the end of this file for more information. -->
 # kiali
 
-![Version: 2.4.0-bb.2](https://img.shields.io/badge/Version-2.4.0--bb.2-informational?style=flat-square) ![AppVersion: 2.4.0](https://img.shields.io/badge/AppVersion-2.4.0-informational?style=flat-square) ![Maintenance Track: bb_integrated](https://img.shields.io/badge/Maintenance_Track-bb_integrated-green?style=flat-square)
+![Version: 2.5.0-bb.0](https://img.shields.io/badge/Version-2.5.0--bb.0-informational?style=flat-square) ![AppVersion: 2.5.0](https://img.shields.io/badge/AppVersion-2.5.0-informational?style=flat-square) ![Maintenance Track: bb_integrated](https://img.shields.io/badge/Maintenance_Track-bb_integrated-green?style=flat-square)
 
 Kiali is an open source project for service mesh observability, refer to https://www.kiali.io for details.
 
@@ -58,7 +58,7 @@ helm install kiali chart/
 | istio.mtls.mode | string | `"STRICT"` |  |
 | port | int | `20001` |  |
 | image.repo | string | `"registry1.dso.mil/ironbank/opensource/kiali/kiali-operator"` |  |
-| image.tag | string | `"v2.4.1"` |  |
+| image.tag | string | `"v2.5.0"` |  |
 | image.digest | string | `""` |  |
 | image.pullPolicy | string | `"IfNotPresent"` |  |
 | image.pullSecrets[0] | string | `"private-registry"` |  |
@@ -104,7 +104,7 @@ helm install kiali chart/
 | cr.spec.istio_component_namespaces.tracing | string | `"jaeger"` |  |
 | cr.spec.istio_namespace | string | `"istio-system"` |  |
 | cr.spec.deployment.image_name | string | `"registry1.dso.mil/ironbank/opensource/kiali/kiali"` |  |
-| cr.spec.deployment.image_version | string | `"v2.4.0"` |  |
+| cr.spec.deployment.image_version | string | `"v2.5.0"` |  |
 | cr.spec.deployment.image_pull_secrets[0] | string | `"private-registry"` |  |
 | cr.spec.deployment.ingress_enabled | bool | `false` |  |
 | cr.spec.deployment.accessible_namespaces[0] | string | `"**"` |  |
diff --git a/chart/Chart.yaml b/chart/Chart.yaml
index 1b0f8131ebc388410f9a660ef856e9bfa670c909..3077ff6e722602ef3feb1d4eff9b23dec557ad26 100644
--- a/chart/Chart.yaml
+++ b/chart/Chart.yaml
@@ -1,8 +1,8 @@
 apiVersion: v2
 name: kiali
 description: Kiali is an open source project for service mesh observability, refer to https://www.kiali.io for details.
-version: 2.4.0-bb.2
-appVersion: 2.4.0
+version: 2.5.0-bb.0
+appVersion: 2.5.0
 home: https://github.com/kiali/kiali-operator
 maintainers:
   - name: Kiali
@@ -24,12 +24,12 @@ dependencies:
 annotations:
   bigbang.dev/maintenanceTrack: bb_integrated
   bigbang.dev/applicationVersions: |
-    - Kiali: 2.4.0
+    - Kiali: 2.5.0
   helm.sh/images: |
     - name: kiali
-      image: registry1.dso.mil/ironbank/opensource/kiali/kiali:v2.4.0
+      image: registry1.dso.mil/ironbank/opensource/kiali/kiali:v2.5.0
     - name: kiali-operator
-      image: registry1.dso.mil/ironbank/opensource/kiali/kiali-operator:v2.4.1
+      image: registry1.dso.mil/ironbank/opensource/kiali/kiali-operator:v2.5.0
     - name: kubectl
       image: registry1.dso.mil/ironbank/opensource/kubernetes/kubectl:v1.30.9
   bigbang.dev/upstreamReleaseNotesMarkdown: |
diff --git a/chart/Kptfile b/chart/Kptfile
index 4a9c1d2256ef32c247a9662e67715cbb9dc3b243..6abb9b3a2d184f5f418798c6202193876f9604b1 100644
--- a/chart/Kptfile
+++ b/chart/Kptfile
@@ -5,7 +5,7 @@ metadata:
 upstream:
   type: git
   git:
-    commit: ccc6dad6d13cf731d496cf2fc84f56ecf0b06bd7
+    commit: f8d78903f1316abcbf389f8a62ddafcc9c1828f4
     repo: https://github.com/kiali/helm-charts.git
     directory: /kiali-operator
-    ref: v2.4.0
+    ref: v2.5.0
diff --git a/chart/values.yaml b/chart/values.yaml
index f88d35afacd6d3e4e9e0fecfd33961e909ef183b..86db9b5441b91748d305e3d9d73fc072b8ebb7c6 100644
--- a/chart/values.yaml
+++ b/chart/values.yaml
@@ -40,7 +40,7 @@ istio:
 port: 20001
 image:
   repo: registry1.dso.mil/ironbank/opensource/kiali/kiali-operator
-  tag: v2.4.1
+  tag: v2.5.0
   digest: "" # use "sha256" if tag is a sha256 hash (do NOT prefix this value with a "@")
   pullPolicy: IfNotPresent
   pullSecrets:
@@ -162,7 +162,7 @@ cr:
     # custom_dashboards: []
     deployment:
       image_name: registry1.dso.mil/ironbank/opensource/kiali/kiali
-      image_version: v2.4.0
+      image_version: v2.5.0
       image_pull_secrets:
         - private-registry
       ingress_enabled: false